Upstream ITDR Outage

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 05:57 UTC

Update

Microsoft's services have recovered. We are now working to process backlogged data.
Posted Oct 29, 2025 - 23:29 UTC

Update

Systems are beginning to recover, however Microsoft estimates at least 4 more hours until full recovery.
Posted Oct 29, 2025 - 20:02 UTC

Monitoring

Microsoft services are currently experiencing an outage preventing ITDR from receiving telemetry. Microsoft is investigating the issue while our team continues to monitor and prepare for recovery.

Refer to Microsoft's status page for more information: https://status.cloud.microsoft/m365
Posted Oct 29, 2025 - 16:36 UTC
This incident affected: ITDR.