ITDR Ingestion Delay

Incident Report for Huntress

Resolved

The upstream latency issues are resolving. Huntress ingestion is operating normally.
Posted Aug 05, 2026 - 22:18 UTC

Monitoring

This is a Microsoft latency issue that is outside of our control. We are continuing to monitor the situation and will update when the feed recovers.
Posted Aug 05, 2026 - 15:27 UTC

Investigating

We are currently investigating this issue.
Posted Aug 05, 2026 - 14:17 UTC
This incident affected: ITDR.