ITDR Detections Are Catching Up

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 00:46 UTC

Monitoring

A fix has been implemented. We are working on data replay.
Posted Mar 18, 2026 - 19:32 UTC
This incident affected: ITDR.